
Introduction to Image Analysis with



PLEASE ENSURE FIJI IS INSTALLED CORRECTLY!



WHAT DO WE HOPE TO ACHIEVE?

Specifically, the workshop will cover the following topics:

1. Opening images with Bioformats

2. Interpreting histograms

3. Basic segmentation

4. Filtering images

5. Intro to morphological quantification

6. Analysis of protein expression



AIMS

• General overview

• Small chunks of theory/demonstration, each 
followed by a practical.

• Challenges

• Break for tea/coffee at 15:30

• Finish about 17:00

FORMAT

• Introduction to image analysis concepts

• Gentle introduction to FIJI



You don’t need to take notes – I will 
send you the slides after the workshop

Please sign the sign-in sheet

Please feel free to ask questions

HOUSEKEEPING



WHY USE QUANTITATIVE IMAGE ANALYSIS?

• Microscopy historically 
qualitative

• New technology 
facilitates 
quantification

• Limited uptake among 
biologists

Experimental 
Outputs

“Representative 
Image”

Experimental 
Outputs

Quantitative 
Data

Modeling

Experimental 
Design



Experimental 
Planning

Image 
Acquisition

Image Pre-
Processing

Image Analysis

Data Analysis & 
Interpretation

• Experimental 
design is an 
iterative process

• High quality images 
absolutely crucial

• Scale up gradually

Fixed 
coverslips

Live cell single 
well

Live cell multi-
well



IMAGE ANALYSIS V IMAGE PROCESSING ?
• Image Processing:

• Enhancement, filtering for noise reduction, image registration, etc.

• Image Analysis:

• Analysis of data contained within an image. For example, quantification of 
cell area.

Processing:

Analysis: DATA
Processing should be kept to a minimum – reduces 

information content in image



TYPICAL IMAGE ANALYSIS WORKFLOW

Image Acquisition

Spatial Resolution

Frame Rate

Exposure Time

Fluorophores

Imaging Modality

Image Pre-
Processing

Background 
Subtraction

Noise Suppression

Segmentation

Separate Objects 
from Background

Manipulation of 
Segmentation

Create Mask 
Image

Analysis

Morphological 
Quantification

Fluorescence 
Analysis

Track Over Time



1. There are several different 
ways to arrive at a solution

2. There is rarely one single 
correct solution



ImageJ:

• Open source

• Public domain, cross-
platform.

• Read most image 
formats (via bioformats).

• Same standard functions 
as proprietary packages.

• Open architecture.

• FIJI:

• Fiji Is Just ImageJ

• Actively maintained, 
with frequent updates.





Let us begin…



IF YOU FORGET HOW TO ACCESS SOMETHING…



UPDATING FIJI



OPENING AN IMAGE
• Don’t Drag & Drop

• Bioformats ensures consistent reading of metadata
• Independent project distributed with FIJI



DEMO 1 – OPENING IMAGES WITH BIOFORMATS

• Import Metamorph (TIFF) Dataset:
• Overview of various options presented in Bioformats GUI
• Illustration of reading of MetaData
• Images can appear black, but pixels have values greater 

than zero



ADJUSTING CONTRAST



WORKING WITH CHANNELS



0 25564 128 192

By default, pixel values are mapped to grey levels…

LOOK-UP TABLES (LUTS)



…but there is no reason why this has to be the case.

Equivalent of Range Indicator



11 11 11 13 14 17 22 37 99 204 255 255 255 224 81 17
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13 14 14 17 28 153 255 255 255 255 255 255 255 224 52 8
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IMAGES ARE JUST NUMBERS

“Solutions to image analysis problems often appear simple, 
particularly when easily accomplished by the human visual system, 

which is complex and poorly understood.”

The human brain is excellent at pattern matching…

…but this can result in us seeing “patterns” that don’t really exist



THIS CAN CAUSE PROBLEMS…

1976, Viking 1 2001, Mars Global Surveyor

Pareidolia is a psychological phenomenon in which the mind responds to a stimulus 
by perceiving a familiar pattern where none exists (e.g., in random data).



Same Size

Which nucleus is brighter?

Which centre circle is bigger?

Same Colour



WHAT’S YOUR POINT DAVE?!?!?

We’re here to learn image analysis – you’re preaching to the choir!

People will very often design an analysis pipeline to confirm what they 

think they see visually….

…which often results in significant frustration.

Expected Result: Humanoids on Mars Actual Result: Big Rock



HISTOGRAMS

A graphical representation of the distribution of numerical data
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INTERPRETING HISTOGRAMS
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BIT DEPTH

Bits per pixel Number of values Range of values

8 28 0 – 255

12 212 0 – 4,095

16 216 0 – 65,535

32 232 0 – 4,294,967,295

Range of values a pixel can represent

Greater bit depth 
means larger file 
sizes



REDUCING BIT DEPTH LOSES INFORMATION

8-bit 7-bit 6-bit 5-bit

4-bit 3-bit 2-bit 1-bit



DEMO 2 – MANIPULATING PIXEL VALUES

• Reducing bit depth incurs loss of data

• Best to deal with raw values
• Operations performed more precise (e.g. lower rounding error)

• Compress for presentation



IMAGE COMPRESSION

• Lossless:

• All image information is preserved 
when saved.

• BMP, TIFF, PNG, Text

• Typically results in large file sizes, 
with the exception of PNG

• Lossy:

• Image information is irretrievably 
lost when saved.

• JPEG, GIF

• Typically results in small file sizes

Lossy Compression: Anything that changes 
pixel values



INTERPRETING HISTOGRAMS FURTHER

“Background”

“Foreground”

Can be exploited for segmentation



WHAT IS IMAGE SEGMENTATION?

• The process of dividing an 
image into different 
regions

• Assigning a label to each 
pixel within an image

• Pixels within a region 
should have similar 
properties

Background

Foreground



𝑇 >
Average of Foreground Pixels + Average of Background Pixels

2

• FIJI has several variations on this 
algorithm

• Each produces different results
• Result referred to as binary (or mask) 

image

ForegroundBackground



Click “Apply” to generate the 
binary image



BOUNDARY BETWEEN REGIONS IS AMBIGUOUS

Segmentation is always an estimate
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UNEVEN BACKGROUND POSES PROBLEMS



BACKGROUND SUBTRACTION



DEMO 4 – CORRECTING UNEVEN BACKGROUND

• Investigate influence of filter radius

• Background subtractor creates an estimate of 
background and removes from image



Filtering can be employed to improve segmentation

ANOTHER OBSTACLE TO “GOOD” 
SEGMENTATIONS IS SPECKLE NOISE…



WHAT IS FILTERING?

• Generally refers to simple arithmetic operations on 
small numbers of pixels



MEAN/AVERAGING FILTERING

243 185 185

19 246 105

225 221 119

Replaces central value with average of all values

243 185 185

19 172 105

225 221 119



FILTERING IN ACTION

Input Output



MeanInput

MEAN FILTERING “BLURS” NOISE

But remember, information is also lost!



MEDIAN FILTERING

Replaces central value with median value

243 185 185

19 246 105

225 221 119

243 185 185

19 185 105

225 221 119



Input

MEDIAN FILTERING PRESERVES EDGES

Median



Gaussian Filter

GAUSSIAN FILTERING

• Approximation of Airy Disk
• Essentially a weighted mean 

filter

Mean Filter

Airy Disk 2D Gaussian



MeanInput

Median

Gaussian

Unfiltered Output Filtered Output

Processing:



DEMO 5 - FILTERS

• Notice the effect of varying filter radius

• Observe the difference in edge preservation 
between mean and median filters



MORPHOLOGICAL ANALYSIS

How do we extract numerical data from segmented images?



MORPHOLOGICAL ANALYSIS







Erosion

Dilation

Erosion + Dilation = Opening

MORPHOLOGICAL FILTERING



Morphological filters can be 
used to:
• Remove small artefacts
• Break “bridges”
• Watershed: break apart 

touching cells 



DEMO 6 – WORKING WITH BINARY IMAGES

• Demo particle analyser and morphological filters

• Show how to specify background colour for analyser



CHALLENGE 1

• Process > FiltersFilter Noise

• Image > Adjust > ThresholdSegment Cells From Background

• Process > BinaryManipulate Segmentation

• Analyze > Set MeasurementsSpecify Morphological Measurements

• Analyze > Analyze ParticlesQuantify Morphology

1. Count the number of cells
2. Estimate the mean cell area

Note: You may find it helpful to duplicate and/or 
rename images as you work



CHALLENGE 1

• Which variables in your analysis pipeline will have the greatest 
impact on your result?

• Could the images be improved in any way to facilitate easier 
analysis?

• Can you think of an alternative approach?

• Process > FiltersFilter Noise

• Image > Adjust > ThresholdSegment Cells From Background

• Process > BinaryManipulate Segmentation

• Analyze > Set MeasurementsSpecify Morphological Measurements

• Analyze > Analyze ParticlesQuantify Morphology



SOLUTION TO CHALLENGE 1



HOW DO PARAMETER VALUES AFFECT THE RESULT?
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USING MORPHOLOGICAL CRITERIA



REPEAT ANALYSIS ON CLUMPED CELLS



ALTERNATIVE APPROACH: REGION-GROWING

Use nuclei as seeds 
for conditional 
dilation



ANALYSING MULTIPLE CHANNELS

What if we want to analyse protein expression?



FIJI restricts measurements to within Regions of Interest (ROIs)

1. Generate an ROI

2. Apply ROI to image

3. Measure the pixel values in the image within the ROI



IT’S POSSIBLE TO SPECIFY ROIS MANUALLY

ROI Drawing Tools



Masks and ROIS can be considered interchangeable

PARTICLE ANALYSER GENERATES ROIS “BEHIND THE SCENES”



1. Using Particle Analyser to generate an ROI

2. Apply ROI to image

3. Measure the pixel values in the image within the ROI



ROI MANAGER CAN ALSO BE ACCESSED MANUALLY…



DEMO 7 – GENERATING ROIS AUTOMATICALLY

Demonstration of Particle Analyser’s ability to generate regions of interest

1. Using Particle Analyser to generate an ROI

2. Apply ROI to image

3. Measure the pixel values in the image within the ROI



Binary Mask

Fluorescent Signal

FIJI will always apply measurements to whatever image is 
specified here



DEMO 8 – QUANTIFYING FLUORESCENCE

Demonstration of Particle Analyser’s ability to apply ROIs to measure grey 
levels



WHAT IF WE WANT TO EXAMINE DIFFERENCES 
IN PROTEIN EXPRESSION…

…between here…

…and here?

Require two different ROIs

1. Generate an ROI

2. Duplicate ROI and manipulate in some way

3. Apply ROIs to image, one at a time

4. Measure the pixel values in the image within the ROIs



Erosion

POSSIBLE TO MANIPULATE MASK PRIOR TO ROI GENERATION

How do we generate a mask to represent the cell boundary?



Calculate difference between these… …to produce this.



CHALLENGE 2

Estimate the difference in mCherry expression 
between the cell edge and the cell centre

• Process > FiltersFilter Noise

• Image > Adjust > ThresholdSegment cells from background

• Process > BinaryManipulate Segmentation

• Process > Image CalculatorCreate New Mask Image

• Analyze > Set MeasurementsSpecify Morphological Measurements

• Analyze > Analyze ParticlesQuantify Morphology & Fluorescence



CHALLENGE 2

• Which variables in your analysis pipeline will have the greatest 
impact on your result?

• Is the result what you expected?
• Why?
• What could explain any discrepancy between what you see 

“visually” and what you obtain quantitatively.

• Process > FiltersFilter Noise

• Image > Adjust > ThresholdSegment cells from background

• Process > BinaryManipulate Segmentation

• Process > Image CalculatorCreate New Mask Image

• Analyze > Set MeasurementsSpecify Morphological Measurements

• Analyze > Analyze ParticlesQuantify Morphology & Fluorescence



SOLUTION TO CHALLENGE 2



Everything we have done can also be applied to 3- & 4-D datasets



CHALLENGE 3

• Process > FiltersFilter Noise

• Image > Adjust > ThresholdSegment cells from background

• Process > BinaryManipulate Segmentation

• Process > Image CalculatorCreate New Mask Image

• Analyze > Set MeasurementsSpecify Morphological Measurements

• Analyze > Analyze ParticlesQuantify Morphology & Fluorescence

Determine whether mCherry localisation 
varies over time
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EASY TO EXTEND THIS APPROACH…

For example, to 
compare nuclear & 
non-nuclear 
expression



ADVANCED TOPICS

• Object Tracking

• Colocalisation analysis

• Writing macros & plugins





https://www.futurelearn.com/courses/image-analysis



LEARN MORE

Crick Advanced Light Microscopy ● SW312 ● calm@crick.ac.uk

mailto:calm@crick.ac.uk




Have a Nice Weekend


